The Psion Organiser II Forum (http://forum.psion2.org/YaBB.pl)
User Forum >> Help >> No Screen
(Message started by: CTYankee310 on Apr 7th, 2018, 12:46am)

Title: No Screen
Post by CTYankee310 on Apr 7th, 2018, 12:46am
Recently took my Psion out of storage. Plugged into outlet to power up. Nothing came up on screen. Moved contrast wheel but still nothing. Is Psion dead or just sleeping? Need expert advice.

Title: Re: No Screen
Post by starhawk on Apr 7th, 2018, 4:28am
Er, how did you "plug in" your PSION? They are made to run from a 9v rectangular battery... please tell me you did not apply mains voltage directly to those contacts!

Title: Re: No Screen
Post by Ted Korab on Apr 9th, 2018, 12:03am
Reference my earlier message where my Psion won't power up. (No screen). I plugged the power supply into the top of the unit instead of using a battery. Do I need the battery also. Book says I don't when using the Mains Adaptor to power the unit.

Title: Re: No Screen
Post by starhawk on Apr 9th, 2018, 12:16am
I've not heard of a mains adapter, although I'm not that experienced with PSION accessories...

I would see if it works on a 9V battery without the mains adapter attached. Power supplies can go faulty over time... capacitors dry up, things get wet and corrode, things just plain get old and cranky... there's a lot that can happen there.

Title: Re: No Screen
Post by jaap on Apr 9th, 2018, 5:50pm
The Psion should work fine without battery when powered through a top-slot adapter or comms link.

If your power supply unit is not one made by Psion, make sure it is providing the right voltage and the correct polarity. It should be about 9V (or 10.5V is fine too), and the inner part of the plug is the positive one. If the polarity is the wrong way around, then the Psion will not work, though it should not cause any damage. If your top-slot adapter has a little red LED in it, you'll see if the polarity is correct.

Remove any datapaks (just in case they are causing the problem).
Connect it up to the power and press the ON/Clear button.

If the organiser does nothing after pressing ON/Clear, and pressing other buttons after that does not cause any click sounds, then it is not switching on. Your Psion may be dead, but there could still be something wrong with the power supply, so it is worth putting in a battery to be sure.

Title: Re: No Screen
Post by CTYankee310 on Apr 10th, 2018, 12:25am
Power supply is a Psion unit. When plugged into top of computer LED light comes on and is red. I press the On/Clear button and turn the contrast wheel still no screen Will put a battery in next, but if this doesn't work where can I have it checked out here in the States ?

Title: Re: No Screen
Post by starhawk on Apr 10th, 2018, 3:12am
Thaaaaaaaaaaaaaaaaaaaaaat's not a good sign.

I really don't think there's anything left of PSION even to service that equipment any more :( you're basically down to trying to find an EE who feels neighborly. Maybe if you live near a local hackspace or makerspace, someone there could help?

I'd offer myself, but I can't do much beyond prodding it with multimeter and logic probe, and I have this feeling that that won't be too useful.



The Psion Organiser II Forum » Powered by YaBB 1 Gold - SP 1.1!
YaBB 2000-2002,
Xnull. All Rights Reserved.