The PSION Organiser II Homepage
Forum Home Forum Home Help Help Search Search Members Members Login Login Register Register

Welcome, Guest. Please Login or Register.
Why register?
   The Psion Organiser II Forum
   User Forum
   Help
(Moderator: Mikesan)
   Link cable
« Previous topic | Next topic »
Pages: 1  Reply Reply Notify of replies Notify of replies Send Topic Send Topic Print Print
   Author  Topic: Link cable  (Read 696 times)
Link cable - scheme
Guest

Email

Link cable
« on: Jan 18th, 2003, 2:47pm »
Quote Quote Modify Modify Remove Remove

I have a trouble - I bought used LZ 64 and I can't connect it to PC - probably PC<->PSION cable is damaged - does someone have a scheme of this cable ?? Please HELP !!
Boris
Administrator




   
WWW

Posts: 552
Re: Link cable
« Reply #1 on: Jan 18th, 2003, 4:11pm »
Quote Quote Modify Modify

http://archive.psion2.org/org2/topcoms.htm describes the cabelling inside the CommsLink, the other side is a standard 25 pin serial plug, which may be replaced by a 9pin one (as the wide one is not used nowadays).

Triholerahduliäöhh gugguh !! (tyrolean joy jodler)
Rough translation: There's a new build of Psi2Win!!
Email: boris[at]psion2[dot]org
ALbi
Guest

Email

Re: Link cable
« Reply #2 on: Jan 19th, 2003, 3:57pm »
Quote Quote Modify Modify Remove Remove

Tnx for help but it's still out of order   Its probably sth. with the interface - I don't know what is wrong. Do you have scheme of interface, maybe ?? I'll try to repair it - it's to expencive for me to buy a new one
droflerf
Member




   


Posts: 21
Re: Link cable
« Reply #3 on: Jan 19th, 2003, 10:20pm »
Quote Quote Modify Modify

what operating system are you running commslink does not run under xp
ALbi
Guest



Re: Link cable
« Reply #4 on: Jan 19th, 2003, 11:08pm »
Quote Quote Modify Modify Remove Remove

I know - i've instaled W98 on second comp - becouse i use XP on one - but it didn't help - There was no response from psion I don't know what is wrong ...
droflerf
Member




   


Posts: 21
Re: Link cable
« Reply #5 on: Jan 21st, 2003, 4:55pm »
Quote Quote Modify Modify

have you set the protocol up as in the manual
Andrew
Guest

Email

Re: Link cable
« Reply #6 on: Jan 23rd, 2003, 9:10pm »
Quote Quote Modify Modify Remove Remove

Someone gave me a comms link with the connector chopped off, so I had the same problem.  I have got mine working, and can give the following info -
 
Colour of wireFunction   Pin No on a 9-pin D
screen  gnd 5
black  gnd 5
brownRTS out8 CTS in
redCTS in7 RTS out
orangeTXD out 2 RXD in
yellowRXD in3 TXD out

 
To make the pc work, you must also join 6 to 4 inside the connector (DSR to DTR).
 
If you have an oscilloscope, procede as follows -
Select TERM on the psion, with RTS HAND and NONE protocol, all other parameters don't care.  Join CTS to +5v. connect the scope to TXD and key some data on the psion - you should see some activity on the TXD line.  If you don't the thing is dead.  If you do it is alive !
 
After all this, mine worked ok.  Best of luck - Andrew
« Last Edit: Feb 10th, 2003, 5:31pm by Boris »
Pages: 1  Reply Reply Notify of replies Notify of replies Send Topic Send Topic Print Print

« Previous topic | Next topic »

The Psion Organiser II Forum » Powered by YaBB 1 Gold - SP 1.1!
YaBB © 2000-2002,
Xnull. All Rights Reserved.
top